Question Relais qui saffole sur Data East Guns N'Roses

axnslash

Membres
Membre FF
Bonjour à tous,
je ne suis pas nouveau sur ce site mais visiblement mon compte a été reset :p

Voilà mon problème, je possède depuis plusieurs années un flipper guns sans aucun soucis et forcément pendant le confinement on joue plus vi_vi, et bien sûr, je rencontre un drôle de problème depuis peu...
En effet, j'ai une séquence de flash du GI et du front panel qui ne devraient pas s'enclencher pendant une mission mais également à la fin de la partie lors du générique de fin.
J'ai le relais RY1 sur la carte d'alimentation qui s'affole, alors qu'il ne devrait pas !!! et le pire c'est que ces séquences se produisent à 90% et les 10 autres % c'est normal !!!
j'ai mis Q28 sur la CM à la masse et mon relais fonctionne bien, je ne comprends pas pourquoi ce foutu relais se met à caviter !!! comme s'il n'arrivait pas à coller, manque de voltage ou relais fatigué ?
J'ai regardé des vidéos de gameplay sur youtube du flipper pour être sûr et oui ces séquences de flashs ne devraient pas être ???
Bref voilà, je sais que David est une pointure, PS je me souviens de son stand à Vierzon quelle époque, recharge de digit syst-1 plus1

Bonne soirée à vous et merci pour vos idées car j'ai cherché toute la journée mais à part un relais fatigué ou un mauvais contact sur un connecteur, j'ai vérifié CN11 CN12 mais rien.

A+

[Titre modifié pour plus explicite que "Panne <Nom du jeu>"]
 

David

Big Boos
Membre du personnel
Big Boos
OUi les titres, pensez à bien les écrire
Avec des infos très utiles, en l’occurrence, nom du jeu, et carte incriminée
 

David

Big Boos
Membre du personnel
Big Boos
Le relais des GI oui il clignote on dira TIC TIC TIC des des fois très rapidement

Rien d'anormal là

Par contre, tu devrais vérifié ton 20v et 34V s'il n'y a défaut
Tu as bien le petit connecteur de 3 voies de bien branché ? Avec le petit fil rouge ?

1588345917773.png

3 ou 5 voies suivant le jeu ....et l'alim ici CN7
 

axnslash

Membres
Membre FF
Bonjour David,

Je viens d'effectuer quelques mesures de tensions sur la carte PS Power Supply :

+34V = mesuré 39,9V
20V = je ne vois pas ou se trouve ces 20V sur le schéma de la PS Power Supply ????

J'ai mesuré en plus les 5v, +12v et -12v :
5V = 5,05V
+12V = +10,08V
-12V = -16,04V

Merci d'avance
 

David

Big Boos
Membre du personnel
Big Boos
Tout me semble bon au niveau des tensions
Regarde les connecteurs alors
Je doute que le relais soit le fautif
 

axnslash

Membres
Membre FF
Bonjour David,

merci pour ta réponse.
D'abord pour le 20V c'est le 18V du schéma que tu me demandais de vérifier ?
 

axnslash

Membres
Membre FF
ce 18V là ?
1588589683681.png
Sinon concernant le relais RY1 de la carte PS Power Supply c'est sûr il n'est pas d'origine, bon après tout rien d'étonnant ce flipper a été 11 ans en expolitation donc...
Par contre, j'ai refait les 8 soudures mais ça n'a rien changé.
Concernant les connecteurs j'ai déjà vérifié mais bon je vais le refaire car 2 fois vaut mieux qu'une, on sait jamais on passe tellement à coté des fois... De plus j'avais refait tous les connecteurs des différentes cartes qui chauffent mâles et femelles il y' a 2-3ans (commande RP, ta pince à sertir est géniale au passage).

Comme je te l'avais dit lors de mon premier poste, j'ai ce relais qui se met en marche lors d'une mission spécifique et c'est lors de cette phase de jeu que je me suis rendu compte du problème, car en effet, lors de la mission Duff ou l'on doit shooter la bille captive, j'ai le Jackpot de la ramp R qui s'allume !!!!!!!!! et ça c'est pas normal. Hier j'ai fait 2-3 essais sans vitre en forçant cette mission et 1 fois cela à été normal, mais toutes les autres fois j'ai le jackpot R qui clignote avec le relais RY1 !!!
Je pris le schéma et il s’avère que cette lampe remonte sur la carte driver via connecteur J9 pin 9 (blk/grn) puis passe par la R5 et D13 (vérifié ok). Par contre, je ne comprends pas le J2-5 qui passe par D5 (J2-5 wht/blu scoop c'est quoi scoop ??) puis repart J1-5 (Sol5) sur CPU en CN11-6 commandé par Q42 (tip122) commandé par Q34 puis résistance R77 le RA10 et enfin le 7408. y'a t-il une fuite sur l'un de ces composants pour avoir cette commande activée dans 80% du temps ??? je comprends pas !!!
1588590819945.png1588590948433.png1588591284239.png1588591396437.png
1588591680453.png1588592000138.png
 

Fichiers joints

  • 1588590635637.png
    1588590635637.png
    83.3 KB · Affichages: 0
  • 1588590929686.png
    1588590929686.png
    12.3 KB · Affichages: 0
  • 1588591345703.png
    1588591345703.png
    38.3 KB · Affichages: 0

axnslash

Membres
Membre FF
Re bonjour,

je viens de repasser du temps à essayer de comprendre d'avantage, je te confirme que le relais continue une séquence finalement sur 3 moments, l'une sur une mission pendant le jeu pendant l'ouverture au multiball et l'autre en en fin de partie pendant le générique de fin.
Pour La mission Duff, elle débute lorsque la bille est éjectée de la capture (sous rampe G) et là en temps normal le relais lance une séquence puis revient à la normal c'est à dire plateau et front panel s’éteignent et s'allument pendant 2-3 séquences . Lors d'un test vitre enlevée la bille s’éjecte avec les 2-3 extinctions (relais tic-tic-tic) le relais revient à la normal c'est à dire plateau et front panel allumés puis quelques secondes une dizaines peut-être, le relais se remet à faire une séquence donc plateau et front panel ainsi qu'uniquement les lampes flash 5R puisque jackpot R (c'est comme ça que je me suis rendu compte du problème) s'allument mais là sans s’arrêter jusqu’à la fin de la mission !!!! et parfois mais très très rarement la séquence se passe bien, c'est à dire : Ejection de la bille séquence de 2-3 extinctions puis retour à la normal jusqu'a la fin de mission, mais c'est extrêmement rare...
1588600909826.png1588601098445.png


Ensuite lors de l'ouverture multiball, normalement je ne devrais avoir que multiball qui s'allume sur la droite et la lumière jaune de la rampe G qui s'allume.
Là j'ai le relais qui s'active dès le début avec le plateau et front panel qui s'allument et s'éteignent ainsi que les flash 8R (2 insert et 2 panel) !!! tiens ça ressemble au problème de la mission Duff ces flash qui ne devraient pas et tout comme le plateau et le front panel !!!
1588602435919.png


et pour la séquence pendant le générique de fin, c'est la même séquence que pour l'attente lancement multiball c'est à dire relais qui n'arrête pas pendant 5-8s, en gros jusqu'à la fin de la music de clôture partie, donc front panel et plateau qui clignote + les flash 8R !!!

Vraiment bizarre le comportement du relais car je tiens à te préciser que tout le reste du jeu fonctionne très très bien.

Merci d'avance et j'espère avoir été assez clair moins1
 

axnslash

Membres
Membre FF
Bon j'ai continué cet aprem à essayer de comprendre.
J'ai remarqué sur le schéma que les 2 groupes de x4 lampes flash 5R x4 et 8R x4 étaient commandées par le même 7408.
Est-il possible que si il y'avait un problème sur le 7408 cela pourrait perturber le relais de la carte d'alimentation, car j'ai remarqué que je n'ai jamais eu le relais qui s'affolait seul mais toujours avec soit 5R mission duff ou 8R multiball et générique de fin.
CN11-SOL.DRV. 5 qui va sur le 7408 (3J)
et
CN11-SOL.DRV. 8 qui va sur le 7408 (3J)
1588614748901.png1588614808462.png

Merci et bonne soirée à vous tous
 

Fichiers joints

  • 1588611949722.png
    1588611949722.png
    149.2 KB · Affichages: 0

David

Big Boos
Membre du personnel
Big Boos
Ah mais les lampes flash sont pas liés au relais de la GI

Mais au relais de la ppboard ;)
Et là souvent les soudures sont HS
 

axnslash

Membres
Membre FF
J'ai déposé la ppboard, refait les 8 soudures sur K1, remontage puis test, mais toujours ce satané problème o_O
clignotement du GI + les 4 flashs 5R ou 8R pendant les 3 étapes décrites plus haut...
 

axnslash

Membres
Membre FF
Pourtant en mode test j’ai pas de problème sur les flasher.
Je sélection clignotant je ferme la porte, j’entends le relais et tous les flasher fonctionnent . J’comprends plus rien.
J’ai fait un mix led et filament sous le plateau et sur certains flasher, cela peut-il provoquer des mauvais comportements de l’électronique ??
 

David

Big Boos
Membre du personnel
Big Boos
J’ai fait un mix led et filament sous le plateau et sur certains flasher, cela peut-il provoquer des mauvais comportements de l’électronique ??

Oh tu sais que j'aime pas les LAIDES de part tous les emmerdes liés et anomalies que cela créé
Mais n'ayant eu fait un test pareil je ne sais pas dire
Par contre je sais une chose, les lampes flashs sont survoltées, et là ta LAIDE va se prendre 30 V dans les dents au lieu de 12 (pour les grosses lampes à laides on dira)
Cela peut sans doute générer des court circuit
Pour en avoir le coeur net, mets des lampes partout
 

axnslash

Membres
Membre FF
Bonsoir David,

c'est fait tout est en filament et c'est toujours idem. J'ai une question, les 34V générés par BR2 sont bien toujours générés en continu et le clapitement du relais se fait via les impulsions commandé par Q28, donc en théorie je devrais toujours mesurer 34V pendant le défaut nan... ??
Je pose cette question parce que j'ai pris une mesure pendant le défaut et je me suis aperçu que le 34V disons plutôt mes 40V variaient à la baisse, donc coupure de ces 40V mais comme c'est ultra rapide je ne descend jamais sous les 35-36V
 

axnslash

Membres
Membre FF
Re bonsoir,

j'arrive pas à comprendre le lien entre le relais du GI piloté par Q28 et la séquence des flasher soit 5R piloté par Q39 ou 8R piloté par Q42 par l'ntermédiaire du relais de la ppboard !!! la seule similitude c'est bien le 34V nan ?
 

David

Big Boos
Membre du personnel
Big Boos
LEs deux relais là oui sont alimentés en +34V
Totu a fait
Les deux sont pilotés par la cpu

Relais GI
et
Relais A / C
Les relais A/C commute la ligne d'alimentation des bobines ou alors des flashs
Le même transistor sur la cpu commande alors OU une bobine OU une lampe flash
De là l'usage des grosses diodes sur la ppboard ainsi que des résistances de 3 Ohm :)

Le fait de commander le relais des GI avec les flash augmente l'effet visuel de pénombre avec flash
Cela rend l'effet plus puissant
 
Haut Bas