Resolu Colonne de lampes commandées sur Banzai Run

Magnetic

Membres
Membre FF
Bonjour à tous,

J'ai remarqué un petit soucis sur le flipper familial: une colonne en allume une autre. Je m'explique: la colonne 3 du plateau du bas n'allume pas les lampes prévues, mais celles correspondantes de la colonne 9 du plateau du haut; en mode test, la colonne 9 dudit plateau allume, elle aussi, la colonne 9. Le manuel indique que ces deux colonnes sont sur 1J7-3.

Comme c'est la première fois que je dois me frotter à une matrice, je vous pose la question à 100 balles: que faire? :confused:

Merci!
 

David

Big Boos
Membre du personnel
Big Boos
Lance voir le test lampes
Et vérifie en mode toutes allumées ce que cela donne
Après lance bien les tests liés lignes colone
Car n'oublie pas tu as deux plateaux, et cela est géré avec la carte spéciale dans le fronton
J'opterai plus pour un connecteur de sortis, car ceux là décidément sont dur à bien postionner avec le plateau du fronton qui gène trop souvent
 

Magnetic

Membres
Membre FF
J'ai vérifié les connecteurs (et pas juste 1J6 et 1J7), tout est en place.
En toutes lampes allumées, ça fait pareil, que ce soit en LO (ce qui devrait désactiver la colonne 9 du haut) ou en HI (ce qui devrait désactiver la colonne 3 du bas). Idem en test par lampe individuelle, ça allume les bonnes lignes mais pas la bonne colonne.
Voila qui est bien mystérieux!
 

David

Big Boos
Membre du personnel
Big Boos
Loooolll error de personne :p MDR je corrige donc .....

Possible alors le transistor sur la Cpu
Je ne vois pas autre chose
 

Magnetic

Membres
Membre FF
Si je lis correctement le manuel, on parle bien de Q62? Étrange, il est d'ailleurs surligné au stabilo... et des composants le long de 1J8 sont cerclés au bic par un ancien propriétaire... cela cache quelque chose, Sherlock iSgratt
 

David

Big Boos
Membre du personnel
Big Boos
Franchement tu devrais mater les cartes, soudures, connectique
Cela sent peut être un bricolage bien caché ....
 

Magnetic

Membres
Membre FF
Hop, démontage de la CPU... qu'est-ce qui a bien pu se passer ici? iSgratt

20200419_174549.jpg
20200419_174644.jpg
En 25 ans, mes parents ont dû l'envoyer 2 ou 3 fois en réparation, pas davantage (comme il est en résidence secondaire, nous y jouons très parcimonieusement).

A part ça, je vois qu'il y a eu des bricolages/réparations, mais mon modeste niveau ne me permet pas de savoir si je m'intéresser à un point en particulier.
La CPU entière:
20200419_174703.jpg

Et le côté composants là où il y a une croix au marqueur:

20200419_174607.jpg

Quelque chose vous saute-t-il aux yeux?
 

David

Big Boos
Membre du personnel
Big Boos
Ce qui est noir est en fait une commande de bobines, dite Special Solenoid
Cela peut être pour un bumper, un slignshot ou l'éjecteur de bille ou suivant manuel et jeu

Si cela à cramé ainsi un contact de ces dits organe est resté tout le temps fermé ou une bobine en court circuit

Pour le PIA est le 7406 ... Ah ahhhh
C'est ce qui est dans la gestion de la matrice à lampes

Tient tient un 74HC08 ...Possible qu'il ne marche pas lui, il est bien conseillé un 7408 et ou 74LS08 et cela peut OUI faire délirer la matrice à lampes
Remplace le, au besoin il y en a sur mon site pro :) --> Restorpinball
 

Magnetic

Membres
Membre FF
David l'oeil de l'aigle, merci sup.

Je passerai commande pour l'expédition du vendredi... pour le 7406 en U56, je peux le laisser?
Sinon, pour ma culture personnelle, quelle différence entre 7408, 74HC08, et 74LS08?
 

David

Big Boos
Membre du personnel
Big Boos
7408 porte standard TTL
74LS08 = Porte standard, rapide et consomme moins
74HC08 = Porte TTL compatible interface CMOS TTL , mais pas les mêmes sortances ou entrances !
A voir un Article TTL OVORUS :) que j'ai écrit il y a bien longtemps déjà .

Juste en disant vite fait la 7408 consomme plus mais est aussi la plus puissante

Sinon il existe aussi 74ACT08 :p là c'est du bon matos aussi :) Vitesse TTL, impédance MOS, puissance TTL
 

Magnetic

Membres
Membre FF
Hop, semi-déterrage car la puce était hors stock de RP un certain temps.
Du coup puce changée -> aucun changement.
Ne sachant trop que faire, je zieute les trois puces qui ont été remplacées: U53 est maintenant ok (74LS08), U56 semble bon (7406, comme la doc), et U54 aussi (?) (HD6821 pour MC6820/MC6821).
Le mystère s'épaissit marto
 

David

Big Boos
Membre du personnel
Big Boos
Hop, semi-déterrage car la puce était hors stock de RP un certain temps.

Bah non lol
J'en ai rentré plus il y a peu :)
Tu avais pas du faire gaffe :p

Sinon là je ne sais pas quoi dire d'autre
Me faudrait la cpu pour le test de cette dernière
Teste encore un peu les diodes proche des transistors
Après direction RP car je ne saurai plus dire
 

Magnetic

Membres
Membre FF
J'ai testé les D14 et D15, qui sont les deux diodes qui semblaient (mot-clef: semblaient) pertinentes pour la colonne: elles étaient bonnes.
Alors j'ai philosophé devant la matrice:
Image2.jpg
Image4.jpg

Et si j'allais jeter un œil à ce Q62? Je me suis aperçu qu'il avait été remplacé, non par un TIP42 mais par un TIP420. Question idiote: sont-ils équivalents? (si oui, c'est l'impasse; si non, c'est sans doute le problème)
 

David

Big Boos
Membre du personnel
Big Boos
Le transistor de la matrice à lampes ne doit être que TIP42 ou TIP42C (le C indique la tension et le C est mieux encore car plus haute tension)
Si cela est un TIP420 il y a un sac car à ma connaissance il n'existe pas de transistor lol :D
 

David

Big Boos
Membre du personnel
Big Boos
OUAI pas facile à voir un D aussi je pense
Donc pas le souci
Mais tout cela à été déjà bricolé
Cela me laisse songeur

Rien n'a été bricolé sur la carte avec les je sais plus tient 5-6 relais
Celle qui est merdiquement positionnée dans le fronton
Car celle là m'en avait fait voir sur un autre jeu
Car cela bascule les plateaux (mode batteurs lampes etc ...)
Pas qu'il y a un twist là

1594154418469.png
 

Magnetic

Membres
Membre FF
D'après ce que je peux en juger vu les soudures, les relais ont peut-être été remplacés. De mon côté, j'ai déjà refait J8 et J9 qui étaient cramés pour la GI, c'est tout.
Dois-je tester ou remplacer quelque chose en particulier?
(je suis surpris car certains fusibles, bien que bons, ont quasiment caramélisé de l'intérieur)
20200708_222749.jpg
20200708_222807.jpg
 
Haut Bas