Resolu Panne display board dataeast 192x64 sur sega maverick

Clems80

Membres
Membre FF
Hello

J'ai remonté un data east maverick intégralement, réglé quelques soucis ici et la, maisil me reste un dernier souci,
Le dot etant hs(manque une puce HVxxxx, me demandé pas pourquoi) j'ai donc monté un pin2dmd, mais voila a ma grande stupéfaction la display board 237-0139-00 ne fonctionné pas non plus..
Apres quelques discution avec David pour éventuellement lui envoyer, j'ai fini par sauter le pas et essayé de la remettre en marche, donc vu qu'elle etait oxydé j'ai fait le bain de vinaigre/eau avec une petite brosse, puis le dremel sur des soudures tres moches pour voir si il resté une once d'etain, changé les supports d'eprom 0 et 3 et refait quelques soudure ainsi que le cable d'alim 5v.
Et miracle elle est repartie, mais j'ai le support carré du cpu 68000 qui merdouille du coup je vais le changer.
Par contre quelques jour apres son bon fonctionnement elle a commence a me faire des bande noire verticale a egale distance sur l'afficheur, donc j'ai essayé des nappes neuves entre cpu/display board et display board et pin2dmd mais toujours pareil, et maintenant elle me fait aussi des bandes toujours allumé sur l'afficheur(ci joint des photos)
Les eproms 27c4001 sont neuves et ceux sont les bonnes en 120ns, je les aient reprogrammes par acqui de conscience.

Alors est ce que ca pourrait venir de mon support de 68000, ou d'une soudure seche sur un autre composant, ou d'un composant ? (Pareil avec un 68000 12mhz neuf)
Si vous avait une idee du composant qui gere le final de l'affichage ? Car j'ai du mal avec le schema(plus complexe qu'une carte cpu enfin c'est pas pareil)
Je suis équipé d'un multimettre et d'une sonde logique si besoin.

Cordialement
Clément

20190214_224132_HDR.jpg 20190207_112343_HDR-1.jpg 20190214_224016.jpg
 

David

Big Boos
Membre du personnel
Big Boos
Si cela est l'état de la carte actuelle elle est pleine d'acide encore

J'ai eu une à faire il y a peu .... idem oxydée
J'ai passé des heures, il y avait une p't1 de piste + rivet coupée ...
Sonde bien le tout, je sais c'est chaud
Mais bon tu n'as pas le choix là

Vu le type de panne, je dirais de voir un peu la partie registre à décalage ..qui génère les bits // en bits série
 

Clems80

Membres
Membre FF
Oui je vais lui refaire un bon bain pour nettoyée les reste d'acide et puis, verifier les pistes et rivets.

C'est quel parti dont tu parle de bits en // vers serie ? Niveau des 74hc240 ?

Au debut elle etait comme ca
20190123_100055.jpg
 

David

Big Boos
Membre du personnel
Big Boos
Il te faudra prendre le schéma et mater les IC ce qu'ils font avec les dataSheet.
Soit ici le décalage est fait par les 74LS166
En fait pour que tu comprennes, l'afficheur marche en série, les données sont en séries, avec une horloge donnée et des commandes qui disons le simplement, permet le décalage des données en série dans tous les pavés de gestion ligne et colonnes, et aussi verrouille la donnée.
Les mémoires sur la carte gestion afficheur sont de types parallèles, soit données de D0 à D8
C'est cela que l'on va mettre en série pour passer sur un fil de data, ici Sdata

Plus je n'irai pas plus loin car tu seras vite bloqué, ces cartes sont pas facile du tout à dépanner et EXTREMEMENT fragiles questions pistes, rivets
Comme je te l'ai déjà dit, vérifie toutes les pistes, passages entre deux faces, rivets ...
 

Clems80

Membres
Membre FF
J'ai commencé a verifier les soudure et les plots, pour l'instant ras
Un puce defaillante n'est pas a exclure je pense,
J'ai un programmateur qui permet de tester la plupart des ci 74lsxxx, serai t'il jouable de fabriquer un cable avec 2 support tulipes pour les tester directement sur la carte sans les dessouder ?
 

David

Big Boos
Membre du personnel
Big Boos
Non tu pourras pas sur un bus liés de données ou adresses car tout interviendra
 

Clems80

Membres
Membre FF
Bonjour,

J'avais laissé le flipper en standby par manque de temps et un peu peur de foutre en l'air la carte..
J'ai réussi a changer le gros support du 68000 qui avait des mauvais contact, le quartz qui etait tout rouillé, et installé des support tulipe pour les SN74LS166AN, par contre c'est grave si ceux sont des SN74LS166 sans le "AN", me reste plus qu'a tester demain, si c'est ok !?
Les continuitées de piste ont l'air bonne la ou j'ai travaillé..

je croise les doigt!!
 

Clems80

Membres
Membre FF
Je n'ai rien dit ceux sont bien bien des sn74ls166an
Par contre ca ne fonctionne toujours pas : /
 

Clems80

Membres
Membre FF
J'ai un doute sur les 62256 u11 u21, leurs pates sont toutes corrodees(pas au niveau de la soudure mais au dessus surtout, et vu que ceux sont les sram elles sont importantes j'imagine !?
20190605_235011.jpg
 
Dernière édition par un modérateur:

David

Big Boos
Membre du personnel
Big Boos
Oui c'est bien oxydé
Clairement il faut les remplacer les deux 62256

Mais comme j'avais du te le dire, elles sont très dures à dépanner ....
Imagine le PAL ou un des 3 PALs !
Après les pistes sont super fines, je te conseille de bien TOUTES les tester et y compris les passages entre deux faces (rivets de métallisation )

Dernièrement j'avais du en refaire une, qui avait été bricolée avant par quelqu'un
J'ai du tout mettre à nu pour trouver la merde de fil entre deux broches, faute d'avoir bricolé inutilement un peu partout
J'ai pesté ce jour là
Bien sur que j'ai majoré mais cela n'a jamais remplis toute la perte de temps
Je l'ai fait on dira pour geste commercial, mais ça je refuserai ce jour, car c'est moi qui avait tout perdu sur le coup là

Soit refait bien tout et très proprement ! Teste toutes les pistes, rivets etc .... mon conseil avisé
 

Clems80

Membres
Membre FF
Oui c'est pas la joie a dépanner cette carte...
J'ai changé les ram surtout que je les avaient en stock mais pas d’amélioration.
j'ai aussi un PAL U16 que j'avais commandé sur ton site, le U8 HD46505SP, et surement des 74xx, je vais continué tranquillement en mode essai-erreur..
 

Clems80

Membres
Membre FF
Trop content ca y est elle refonctionne ! J'ai changer les 2x 74ls273 u13 et u23, et voila !!
Merci beaucoup pour ton aide David depuis le debut tu m'avait dit que c'etait dans ce coin la !
 

David

Big Boos
Membre du personnel
Big Boos
Impeccable alors

Affaire 17742 classe en résolue et bien rangée dans les tiroirs d'FF :p
 
Haut Bas