Fathom : problème dés qu'une boule est capturée en haut

L

leclos38

Non Membre
Bonjour,

Voila, j'ai enfin trouvé un Fathom et j'ai commencé à le restaurer :
- démontage et nettoyage des éléments du plateau (on ne voyait même pas les décors tellement il était sale !),
- changement des plastiques abimés, des élastiques et des ampoules,
- changement des condensateurs chimiques de la carte son (car il n'y avait plus de bruitages),
- ...

Et maintenant, me voici devant un problème plus complexe : quand une boule est capturée dans le trou du haut, il se passe une chose étrange : le message "Help me !" retentit en boucle et à chaque fois 50000 points sont ajoutés au score ! Ce phénomène intervient de manière aléatoire et ne perturbe pas le jeu.
Lorsqu'une boule est capturée dans le trou inférieur, le problème ne se produit pas...

J'ai vérifié tous les contacts et toutes les bobines en mode test et tout est normal...
Merci de me donner un petit coup de main si vous avez une idée !

Leclos38.
 

David

Big Boos
Membre du personnel
Big Boos
Pour moi ce serait un soucis de lecture des contacts
Mais tu as fait le test apparemment

N'y aurait il pas un faux contact tout simplement
Essaye de nettoyer ce dernier et d'en voir l'écartement aussi
De même dessoude pour voir le condensateur de 50 nF quie st en // sur le contact
 
L

leclos38

Non Membre
Ok, je vais nettoyer le contact, changer le condensateur et refaire les essais.
Pour les tests que j'ai effectué, le plateau était levé, j'ai activé les contacts avec le doigt. Il est vrai que la bille entraine peut-être un comportement différent...
Merci pour ton aide.

Leclos38.
 

medusa

Membres
Membre FF
bizarre quand même - je ne pense pas qu'il y ait un condo sur le contact de l'outhole, car il n'y a pas de raison pour cela

devant l'outhole, par contre, il y a un rollover en forme d'étoile - c'est celui-ci qui produit le 'help me' si mes souvenirs sont exacts et ce contact est sûrement un candidat à avoir un condo, car la bille passant rapidement dessus, la cpu serait trop lente à reconnaître le passage de la bille sans condo

condo ou pas condo, de toute façon, je pense que ton problème se situe au niveau du contact 'étoile'
 
L

leclos38

Non Membre
Bonjour,

J'ai pris un peu de temps pour vous répondre car le problème étant alléatoire; j'ai dû faire pas mal d'essais pour y voir un peu plus clair.
1 - Effectivement, il n'y a pas de condensateur sur le contact de l'outhole. J'ai donc essayé d'en mettre un pour voir si cela améliorait les choses, mais ce n'est pas le cas.
2 - Je me suis aperçu que quand il se mettait à boucler sur le "Help me !", le fait de descendre une cible (uniquement celles qui sont les unes à côté des autres) permettait de l'arrêter.
3 - Suite à ton dernier message sur les rollovers j'ai fait quelques essais de ce côté là et je me suis aperçu que le fait d'appuyer sur le dernier rollover près de l'outhole stoppe le "help me !" mais si je relâche, le message reprend. De plus j'ai vérifié les contacts de ces rollovers : ils fonctionnent, mais je les trouve un peu durs...

4 - Est-il normal qu'avant chaque nouvelle boule (quelque soit le joueur), si une balle est capturée, il y a un "Help me !" et 50000 points.
5 - D'après ce que je comprends de ton message : le condensateur sert à augmenter la durée de l'impulsion sur le contact afin que la CPU ait le temps de l'acquerir. Est-ce exact ?

Merci pour votre aide précieuse !
Leclos38.
 
L

leclos38

Non Membre
Au dernier test, la boule capturée en haut a été libèrée lors d'une remontée des cibles de droite alors que les trois cibles devant la boule n'avaient pas été descendues...
Ne pourrait-il pas y avoir un problème du côté de la ROM de jeu ?
 

David

Big Boos
Membre du personnel
Big Boos
Pour le condo entièrement d'accord

Mais non seulement cela mais pour les parasites de lignes ;)

Pour La rom je ne saurais te dire car le test Bally semblerait fiable niveau Eproms ou Rom mais dernièrement j'ai remis cela en question ....

Dans les tests contacts, et bobines tout semble OK à 100 %
 
L

leclos38

Non Membre
Effectivement, j'ai lu tes messages sur le problème des tests ROM. C'est pour cela que je me posais la question...

Au niveau des tests bobines, tout est ok à part celle du monayeur, mais vous m'avez rassuré à son sujet.
Pour les contacts, je les ai tous testés un à un. Pas de soucis non plus si ce n'est le fait que je trouve certains rollovers un peu durs quand on les actionne avec le doigt. J'émets donc des doutes si la boule passe dessus.
Ce que je n'ai pas encore fait, c'est le remplacement de leur condensateur...
 

David

Big Boos
Membre du personnel
Big Boos
A voir possible les mémoires mais je ne puis donner un avis avec certitude .
 
L

leclos38

Non Membre
Bonjour,
De nouveaux essais pour essayer de cerner le problème m'enduisent encore plus de doutes :
- Maintenant il reset de manière alléatoire. N'y aurait-il pas un problème d'allimentation ?
- Quand j'active le batteur droit (2 batteurs), il est vrai que je vois l'intensité lumineuse des ampoules
qui baisse sensiblement... Ne devrais-je pas commencer par installer deux beaux ponts de diodes
de 35 A comme indiqué dans les "astuces" ? (les condensateurs de la carte solénoïdes et son ont été
remplacés).
- De plus, je trouve les batteurs un peu faibles. David, peux-tu me dire quelles bielettes je dois choisir
sur RP pour les remplacer ?

A chaque pas en avant, je fais deux pas en arrière... Mais on va y arriver !!
Merci pour votre aide,

Leclos38.
 

David

Big Boos
Membre du personnel
Big Boos
Pour les batteurs et autres soucis, il faudra que tu refasse l'alim, et la connectique

Cela sera la priorité avant tout ;)

Les biellettes sont des SYs80 Bally, génération 80 sur RP
 
L

leclos38

Non Membre
Bonsoir,

C'est effectivement ce que je me suis dit : d'abord refaire l'alim et voir si le problème persiste et est plus facilement identifiable...
Tu as dû voir passer ma commande pour remettre tout ça en état, y compris les biellettes...
On en reparle dés que j'aurai fait parler le fer à souder !!
Leclos38.
 

David

Big Boos
Membre du personnel
Big Boos
oki
vivi j'ai vu la commande ;)
 
J

joedalton

Non Membre
tiens au fait un ptit site sympa pour les amateurs de fathom

http://www.pinball.yoo-design.com/


frank
 
Haut Bas